Twitter: raymondcamden


Address: Lafayette, LA, USA

Cordova 3.5 and the "What's Next" Guide

05-27-2014 7,070 views Mobile, JavaScript, HTML5 20 Comments

Over the holiday weekend Cordova 3.5.0 was released. You can read details about the update here: Apache Cordova 3.5.0. Another update was to the documentation, which now includes a What's Next guide that talks about what Cordova developers should learn, think about, and bookmark for future reference after they've learned the basics. I think this is an important piece of documentation and I'm happy to see it finally published. (Oh, and I may be a bit biased as I wrote the first draft. ;)

Also released is a new Security Guide for Cordova developers. Definitely check this out as well.

20 Comments

  • Mike #
    Commented on 05-27-2014 at 2:46 PM
    In the What's Next guide there are asterisks after a lot of links. What's This? Curious only because JQM seems like only UI without it and I use JQM.

    Thanks for writing it!
  • Commented on 05-27-2014 at 3:00 PM
    It is a CSS style for external links.
  • Mike #
    Commented on 05-27-2014 at 4:26 PM
    Hmm, did not know that. I recall it pointing to footnotes. JQM link is broken too.
  • Martin Cisneros #
    Commented on 05-27-2014 at 7:10 PM
    Thank you Raymond!
  • Commented on 05-29-2014 at 7:24 AM
    Phonegap still is 3.4 when I try to install via Node.js.
  • Commented on 05-29-2014 at 7:26 AM
    PhoneGap lags a bit behind Cordova. The Cordova CFL is at 3.5, as the title of this blog post says. The PhoneGap CLI is not yet there.
  • pagc53 #
    Commented on 06-03-2014 at 8:40 PM
    But I couldn't find latest download link(cordova-3.5.0-src.zip). Please help me to get that. Thank you.
  • Commented on 06-03-2014 at 8:44 PM
    For the SDK? You install via npm now.
  • pagc53 #
    Commented on 06-03-2014 at 8:51 PM
    Frankly I don't know anything about that, I'm just a dumb beginner to this one. Please redirect me to some URL for those steps. I think first of all I need to download SDK to start but don't know where is the URL of SDK(latest 3.5 version). Thank you again Ray.
  • Commented on 06-03-2014 at 8:54 PM
    I'd start here: http://cordova.apache.org/docs/en/3.5.0/guidecliindex.md.html#The%20Command-Line%20Interface
  • Andrea #
    Commented on 06-07-2014 at 9:27 AM
    Hi, i've followed setup instructions (npm and sdk download)

    Now i have Phonegap (3.5) and android API 19 BUT on the android emulator the demo project (Phonegap coreate ProjectName) does not work!
    It seembs Device Ready event is not fired (or catched)

    Any solution?
    Regards
    Andrea
  • Commented on 06-07-2014 at 12:04 PM
    So to be clear, you didn't modify the default project?
  • Joe #
    Commented on 06-11-2014 at 3:48 PM
    Same problem as Andrea, but on real device.

    npm install -g phonegap
    phonegap create hello
    cd hello
    phonegap build android
    phonegap install android

    "Connecting to device" never changes to "Device is ready". Added some console.log output to verify that all of the initializing and binding is taking place, but deviceready is never triggered.

    Any advice?

    Thanks,
    Joe
  • Commented on 06-11-2014 at 4:05 PM
    Try Chrome Remote Debugging and see if something is fubared.
  • Joe #
    Commented on 06-12-2014 at 8:40 PM
    Thanks, I'll give it a try (if I can ever get remote debugging to work on this cheap Verizon tablet).
  • Joe #
    Commented on 06-13-2014 at 3:26 PM
    Maybe this is just a newbie misunderstanding, but I had to edit the index.html created by "phonegap create" and change "phonegap.js" to "cordova.js" in order to get it to work.
  • Commented on 06-13-2014 at 4:41 PM
    Weird. Please file a bug report though, ok?
  • Scott Davey #
    Commented on 06-22-2014 at 5:54 AM
    Hi Mike,

    It seems the 3.5 release is not available as a zip. Do you know anything about that?

    I know npm is the preferred approach (and I've done that), but the tutorials for Visual Studio suggest downloading the zip instead, so either they need updating or the zip needs to be made available.'

    Thanks!
  • Stefano #
    Commented on 06-29-2014 at 7:24 AM
    Same issue for me, after upgrading, no more deviceready.

    I had the same problem with v3.4, but I don't remember the solution.

    Any Idea?
  • Commented on 06-29-2014 at 10:45 AM
    So to be clear, in the simplest app possible, deviceready is never fired? Did you try the default app used w/ create?

Post Reply

Please refrain from posting large blocks of code as a comment. Use Pastebin or Gists instead. Text wrapped in asterisks (*) will be bold and text wrapped in underscores (_) will be italicized.

Leave this field empty